Website Browser Compatibility

Despite continually doing our very best to ensure the ultimate browsing experience for our website visitors, it could be that our websites might not display just as perfectly in your browser as we would like them to, especially if you are using an older version of Internet Explorer. Furthermore, with Internet Explorer 8 your browsing experience could be affected by the security settings of your browser.

Thank you for visiting esmo.org!

This website is optimised for the following browsers:

Windows

  • Internet Explorer 9 or higher
  • Firefox 4.0 or higher
  • Safari 5.1 or higher
  • Google Chrome 14.0 or higher
  • Opera 11.1 or higher

OSX

  • Firefox 4.0 or higher
  • Safari 5.1 or higher
  • Google Chrome 14.0 or higher
  • Opera 11.1 or higher

Depending on the security settings of the version of Internet Explorer 8 you might be using, we cannot guarantee its full compatibility with our website. We recommend to use an higher version if at all possible.